Instrument panel voltage regulator

General Discussion about the Datsun PL510
Redrider
Posts: 12
Joined: 24 Jun 2016 09:00
Location: Mission, BC

Instrument panel voltage regulator

Postby Redrider » 27 Jun 2017 15:13

I am wondering if someone could advise me on where the instrument panel voltage regulator on a 72 510 is. I do not have a relay on the back of my gauge cluster and am assuming that there is one mounted elsewhere. Thanks in advance for the help and advice.

datzenmike
Supporter
Posts: 5258
Joined: 24 May 2006 12:40
Location: Van. Isle.

Re: Instrument panel voltage regulator

Postby datzenmike » 27 Jun 2017 20:33

I think the regulator in the gauge cluster itself. Trouble shoot first before tearing the dash apart.

As the regulator works both gauges, if one is working.... it's not the regulator.

If you ground the sender wire for the temp gauge the gauge will read full scale hot. Grounding the sender in the gas tank will show a FULL reading. If either or both gauges do this, the gauges are working. If when connected to their respective senders they fail to read, then the sender is bad or in the case of the fuel tank, the tank may not be properly grounded or the float stuck also. (I'm assuming the engine is warm at least, and the fuel tank not empty)
"Nissan 'shit the bed' when they made these, plain and simple." McShagger510 on flattop SUs

Redrider
Posts: 12
Joined: 24 Jun 2016 09:00
Location: Mission, BC

Re: Instrument panel voltage regulator

Postby Redrider » 28 Jun 2017 10:00

Thanks for your response...I appreciate it. Pretty sure at this point that it is a regulator issue as both fuel and temp gauges fluctuate in tandem constantly rising and falling. Just wondering where the regulator is as my 72 510 does not have one mounted on the back of the instrument panel board.

User avatar
MikeY
Posts: 363
Joined: 26 Jun 2003 16:25
Location: Qualicum Van Isle

Re: Instrument panel voltage regulator

Postby MikeY » 28 Jun 2017 10:15

Isn't this dodad under the gauges the regulator?
Attachments
IMG_20170628_100936-1105x945.jpg
IMG_20170628_100936-1105x945.jpg (190.75 KiB) Viewed 362 times

User avatar
MikeY
Posts: 363
Joined: 26 Jun 2003 16:25
Location: Qualicum Van Isle

Re: Instrument panel voltage regulator

Postby MikeY » 28 Jun 2017 10:21

Maybe it's as easy as cleaning up the contact points where the gauges attach to the board and the board attaches to the back of the circuit board.. Cleaning all the contact point on these old circuit boards sure helps the lights.

510rob
Moderator
Posts: 4587
Joined: 09 Oct 2003 23:37
Location: Vancouver, BC
Contact:

Re: Instrument panel voltage regulator

Postby 510rob » 28 Jun 2017 11:48

The friends over at Ratsun had/have some good insights into this issue.

http://community.ratsun.net/topic/54598 ... asy-2-fix/

Redrider
Posts: 12
Joined: 24 Jun 2016 09:00
Location: Mission, BC

Re: Instrument panel voltage regulator

Postby Redrider » 28 Jun 2017 11:55

Thanks guys I really appreciate the time and trouble. Were onto it now.

User avatar
toylet
Supporter
Posts: 481
Joined: 07 Sep 2007 20:54
Location: Mesa AZ

Re: Instrument panel voltage regulator

Postby toylet » 28 Jun 2017 21:22

I just installed a 9v regulator on my gauges.. both working as designed now.


Return to “General Discussion”



Who is online

Users browsing this forum: No registered users and 3 guests