Page 1 of 1

Momo wheel installed... but difficulties with the momo hub...

Posted: 12 Feb 2020 10:18
by shaddai
Howdy,

I got tired of the ghetto Grant wheel the previous owner installed, so I finally picked up a new Momo wheel and hub. The wheel looks amazing... but the hub was kind of sloppily formed and tight. I was able to get it mostly installed but there's a gap between the back of the hub and the horn wiring/metal piece/thing/whatever you call it... the old Grant hub also had the same issue... so there's no horn functionality.

Anyways... I tightened the s#$@(*& out of the hub to get it installed and as close as I could, but there's still 1/3" or so of a way to go. Thoughts? Is there something wrong with the hub? The steering column? Me?

Did anyone else have issues with the momo hub? Also... the turn signal cancel prongs seem to be rotated 90 degrees from stock. It seems to work okay so far, but it's not perfect. Also... I installed it off by a couple of degrees. Damnit... have to take it off and do it again.

Pics for clicks.

Re: Momo wheel installed... but difficulties with the momo hub...

Posted: 12 Feb 2020 10:19
by shaddai
And it ate an attachment...

Re: Momo wheel installed... but difficulties with the momo hub...

Posted: 12 Feb 2020 11:57
by bertvorgon
Here is a picture of my Momo hub...there is a gap...did you carefully bend the horn power metal strip down a tad to contact the ring?

Re: Momo wheel installed... but difficulties with the momo hub...

Posted: 12 Feb 2020 13:05
by shaddai
bertvorgon wrote:
12 Feb 2020 11:57
Here is a picture of my Momo hub...there is a gap...did you carefully bend the horn power metal strip down a tad to contact the ring?
No... but I will do that.

Re: Momo wheel installed... but difficulties with the momo hub...

Posted: 13 Feb 2020 07:07
by Fred_L-P
There's also a gap on mine and I was wondering if it was normal... I thought maybe the column plastic was cut down by previous owners for another hub. I guess it's normal... I did not check if the tab makes contact with the hub.

Image

Re: Momo wheel installed... but difficulties with the momo hub...

Posted: 13 Feb 2020 13:00
by shaddai
Okay... I pulled it off, adjusted it (straight was not straight... damn it), and bent the horn connector thing and it's alive now! (don't) Mind the gap?

Re: Momo wheel installed... but difficulties with the momo hub...

Posted: 13 Feb 2020 13:08
by bertvorgon
Glad that worked. I remember when I installed mine I wondered...What the hell!

Re: Momo wheel installed... but difficulties with the momo hub...

Posted: 14 Feb 2020 20:10
by funwithmonkeys
Mine is the same. That is just the way they are. For the turn signal cancel prong I cut mine off the drilled and tapped a hole where it should be and put in a set screw sticking out the correct amount. I got tired of the turn signals canceling as soon as you move the wheel one direction and not canceling at all the other direction.

Re: Momo wheel installed... but difficulties with the momo hub...

Posted: 15 Feb 2020 10:56
by shaddai
funwithmonkeys wrote:
14 Feb 2020 20:10
Mine is the same. That is just the way they are. For the turn signal cancel prong I cut mine off the drilled and tapped a hole where it should be and put in a set screw sticking out the correct amount. I got tired of the turn signals canceling as soon as you move the wheel one direction and not canceling at all the other direction.
I thought about doing that... but it seems like way too much work...

Re: Momo wheel installed... but difficulties with the momo hub...

Posted: 15 Feb 2020 11:07
by funwithmonkeys
It took 20 min....