I need help

New posts disabled. Archived technical discussion about the Datsun PL510
dat5102dr
Posts: 214
Joined: 27 Aug 2011 20:44
Location: Gardena CA

I need help

Postby dat5102dr » 04 Sep 2011 15:38

when i take out my datsun and i give it gas it feels like its not wanting to go
it runs but i have to keep it really slow but it still changes gear
my father says its not getting enough power
at first he thought it was the clutch
I am not sure
does anyone have a clue?

User avatar
defdes
Supporter
Posts: 4958
Joined: 12 May 2005 14:45
Location: Vermont

Re: I need help

Postby defdes » 04 Sep 2011 16:31

It sounds like it could be a timing or fuel delivery issue, do you feel/hear/smell the clutch slipping. We'll need a bit more history and detail on the car to successfully help you.

User avatar
James
Posts: 2028
Joined: 26 Nov 2007 19:58
Location: Laguna Beach, Ca

Re: I need help

Postby James » 04 Sep 2011 16:37

OK - list of questions - answer them all and we can probably help you.

1. have you been driving car regularly - new gas etc.?
2. Is car manual or automatic?
3. Stock carb/engine?
4. Points/electronic distibutor?
5. What if anything have you messed with/replaced recently?

I agree with defdes - but some more info would help us point you in the right direction.
Finished is better than perfect......

User avatar
510-Trevor
Supporter
Posts: 1362
Joined: 03 Mar 2007 18:34
Location: Calgary, Alberta

Re: I need help

Postby 510-Trevor » 04 Sep 2011 16:38

If you post your location in your profile, someone local may offer to come over and help.
1972 Yellow 4dr - 1972 Red 2dr

datzenmike
Supporter
Posts: 5173
Joined: 24 May 2006 12:40
Location: Van. Isle.

Re: I need help

Postby datzenmike » 04 Sep 2011 18:09

If it takes off alright and drives fine at low speed but but quickly starts to jerk and stutter like you are turning the ignition off and on when you accelerate, the fuel filter may be full of dirt. They are cheap so just get one and replace it if you do not know when it was replaced last.
"Nissan 'shit the bed' when they made these, plain and simple." McShagger510 on flattop SUs

dat5102dr
Posts: 214
Joined: 27 Aug 2011 20:44
Location: Gardena CA

Re: I need help

Postby dat5102dr » 06 Sep 2011 15:33

I think it was the carb
my dad took out the big filter and push something in and he said that was the problem
Ill try to take it out for a little cruise today to make sure
Has anyone had that problem before?

User avatar
RonM
Supporter
Posts: 1740
Joined: 16 Aug 2010 20:42
Location: SF, East Bay, 510 area code

Re: I need help

Postby RonM » 06 Sep 2011 15:46

Not sure what you father "pushed in" to fix the filter, but yes a clogged filter would cause those symptom, and it's pretty common. Get back to us with a follow up on how it running.

Good luck/
Last edited by RonM on 06 Sep 2011 16:25, edited 1 time in total.
Sometimes people loose touch with subjectivity, because they've got they're heads stuck too far up they're own,,, Reality.

User avatar
two_68_510s
Supporter
Posts: 3614
Joined: 18 Apr 2010 11:20
Location: Ben Lomond California
Contact:

Re: I need help

Postby two_68_510s » 06 Sep 2011 16:00

Must have been the choke, it may have been sticky.
Joel

2 '68 510 2 door sedans
'95 240SX
74 Jensen Healey

“We will either find a way, or make one.” – Hannibal

User avatar
James
Posts: 2028
Joined: 26 Nov 2007 19:58
Location: Laguna Beach, Ca

Re: I need help

Postby James » 06 Sep 2011 16:21

dat5102dr wrote:I think it was the carb
my dad took out the big filter and push something in and he said that was the problem
Ill try to take it out for a little cruise today to make sure
Has anyone had that problem before?


A few pics - would really clear things up. Hope you got it fixed.
Finished is better than perfect......

dat5102dr
Posts: 214
Joined: 27 Aug 2011 20:44
Location: Gardena CA

Re: I need help

Postby dat5102dr » 08 Sep 2011 20:36

That was the problem
The Carb had something sticking out (under the filter)
Does anyone know what causes that?

User avatar
two_68_510s
Supporter
Posts: 3614
Joined: 18 Apr 2010 11:20
Location: Ben Lomond California
Contact:

Re: I need help

Postby two_68_510s » 08 Sep 2011 20:40

Can you be a little more specific?

What was the problem?
Sometimes the threads are not in order, and you need to reference your responses
What was sticking out, and what happened to it?
Joel

2 '68 510 2 door sedans
'95 240SX
74 Jensen Healey

“We will either find a way, or make one.” – Hannibal

dat5102dr
Posts: 214
Joined: 27 Aug 2011 20:44
Location: Gardena CA

Re: I need help

Postby dat5102dr » 11 Sep 2011 12:36

I was two cylinder looking tubes that are there in the card
i pushed them in and it clicked
Before when i drove the car
i gave it gas it would sort of bounce
my dad said it was not getting enough strength
It ran and it changed gears but it would not go fast
Does anyone know what causes that?

User avatar
510-Trevor
Supporter
Posts: 1362
Joined: 03 Mar 2007 18:34
Location: Calgary, Alberta

Re: I need help

Postby 510-Trevor » 11 Sep 2011 13:05

IMO, at this point, your inability to communicate using automotive terminology tells me that you are in over your head. If you really want some help and are not just some troll seeing how far he can take this, post some pics of the parts you are trying to describe. Answer the questions we are asking and post your location and ask if there is somebody nearby that can help you. Next, go buy one of the recomended repair manuals.
1972 Yellow 4dr - 1972 Red 2dr

User avatar
James
Posts: 2028
Joined: 26 Nov 2007 19:58
Location: Laguna Beach, Ca

Re: I need help

Postby James » 11 Sep 2011 13:13

I agree - not getting much back at this point that is useable, much less legible. Picture is worth 1,000 words, probably 10,000 in this case.
Finished is better than perfect......

User avatar
banzai510(hainz)
Posts: 3685
Joined: 24 Mar 2004 07:01

Re: I need help

Postby banzai510(hainz) » 11 Sep 2011 20:46

Though my writting was bad.

What I can make out hes talking SUs

Best to sell the car or learn L motors really fast. There simple motors

olddatsuns.com


Return to “Technical - Archive”



Who is online

Users browsing this forum: No registered users and 2 guests