Steering shaft splines at steering wheel hub

New posts disabled. Archived technical discussion about the Datsun PL510
User avatar
jonmorine
Posts: 173
Joined: 16 Aug 2007 10:55
Location: New Brunswick Canada
Contact:

Re: Steering shaft splines at steering wheel hub

Post by jonmorine » 18 Jul 2009 16:12

qwik510 wrote:
jonmorine wrote:I know this thread is a year old but I was going to remove my steering wheel to put a new one on and I am not seeing how the horn pad comes off.

I have the wheel removal kit so I should be good once I can actually see the nut. I have done it in a couple other cars but the pad would just pop off. This one doesn't seem to be the case unless I am just not pulling hard enough. It sounds like its ripping so I just want to be sure I am not busting the pad.

Anyone have any idea how this comes off?

If it is a stock steering wheel like this:

Image

Grab it in the middle of the pad, push in and twist counter clockwise. Same thing for the smaller SSS wheel pad.
It is that wheel. Thanks for the answer.
2009 Subaru STI
1969 Datsun 510
2009 VW Rabbit

User avatar
jonmorine
Posts: 173
Joined: 16 Aug 2007 10:55
Location: New Brunswick Canada
Contact:

Re: Steering shaft splines at steering wheel hub

Post by jonmorine » 18 Jul 2009 16:13

okayfine wrote:The first time you might want to disconnect the battery or the horns. With little practice you can get the pad off quick enough not to bother.
HAHA. I figured that out when I was trying to get it off the first time.
2009 Subaru STI
1969 Datsun 510
2009 VW Rabbit

YOUGOTERIC
Posts: 1
Joined: 10 Sep 2009 10:18

Re: Steering shaft splines at steering wheel hub

Post by YOUGOTERIC » 10 Sep 2009 10:21

Does anyone know if a steering wheel from a 240Z will fit a 510?

goichi1
Supporter
Posts: 4030
Joined: 22 Jan 2008 21:57
Location: Oak harbor, WA 98277

Re: Steering shaft splines at steering wheel hub

Post by goichi1 » 13 Sep 2009 04:57

IT should fit just fine, but the little pins that cancel the blinkers are 90 degrees off, so you might have problems with that.....but it should bolt right on.

Post Reply