Page 1 of 1

S13 redtop SR20DET timing weirdness

Posted: 17 Jan 2016 18:33
by jovial_cynic
I've been banging my head on this for a little while, and I want to figure out what I'm missing.

My timing is running crazy advanced. Like, maybe 50, 60 degrees advanced even with CAS fully turned back? Obviously, pinging within seconds of starting the engine.

I went through and checked all of the mechanical timing, and everything looks good:

1. Top dead enter with links matched up with notches on the cam sprockets - check.
2. CAS body mark lined up with second dot on CAS gear - check.
3. Timing indicator aligned with the second-to-the-left dot - check.
4. Spark gap at .028 for each plug - check.

Everything seems correct. However, when I've got the timing light connected to the loop-wire that's meant to be used for checking timing, the spark timing is so far advanced that I have to go to the other side of the car to even find the timing marks. It's madness.

I *think* I've got good gas in it, but to rule out a fuel issue, I'm going to dump the tank and refill with high octane.

For the timing to be THAT far off, what else could it be? I'm half-tempted to pull the CAS and intentionally gear it back a step to address the issue, but that seems like a rather wonky "solution" that could lead to other issues.

Re: S13 redtop SR20DET timing weirdness

Posted: 17 Jan 2016 19:14
by okayfine
Any trouble codes from the ECU?
CAS could be bad, or giving a bad reading that the ECU is using.

Provided you're reading timing correctly (I haven't heard about the loop wire, I did it the old-fashioned way, which may have been an error on my part, but I didn't know different and didn't have an issue), it's going to be electrical (not fuel). Even modern fuel that's been sitting around will still light off fine. Whitebird sat for 1.5 years with gas in the tank and I didn't have running issues once I finished the final SR swap.

Re: S13 redtop SR20DET timing weirdness

Posted: 17 Jan 2016 21:26
by jovial_cynic
I've done some additional reading, and it is possible that I've pulled timing source from the wrong wire (which means a different cylinder), which could explain the massive reading error from the timing light.

I'll cobble together a test lead to go between the coil pack and the spark plug tomorrow and see if that gets me dialed in closer.

The pinging is bad regardless. I still need to get that figured out.

Re: S13 redtop SR20DET timing weirdness

Posted: 17 Jan 2016 22:03
by icehouse
I've always done it with the spark plug wire in-between the coil pack and the spark plug. I have a dial back timing light with a million settings. I always use my old school light for a base line. What kinda light do you have?

Re: S13 redtop SR20DET timing weirdness

Posted: 18 Jan 2016 07:51
by jovial_cynic
I ran the test lead (basically a spark plug wire) between the coil pack and the plug and got a better signal.

I do have a dial-type timing light that has proven to be pretty accurate on my previous engine build.

After getting signal from plug #1, it looks like I may only be about 35 degrees advanced, even with the CAS dialed all the way back. Still too far advanced, but not as catastrophic as previously though.

So... I'm going to keep hunting things down until I isolate the problem. There may have been some modifications to this engine before I got it... The cam sprockets don't look like the ones I've seen online (they are solid; no holes in them), so there may be other things that have been changed. I can't tell by looking what is stock and what isn't, as this is the first SR I've ever worked on.

Re: S13 redtop SR20DET timing weirdness

Posted: 18 Jan 2016 17:53
by Three B's Racing
Here's how I do my S14 NA and yes I realize you have DET.

1. Start engine and warm it up until engine coolant temperature indicator points to the middle of the gauge. Ensure engine speed stays below 1,000 rpm.
2. Run engine at about 2,000 rpm for about 2 minutes under no-load [this means turn off all accessories].
3. Rev engine two or three times under no-load, then run engine at idle speed for about 1 minute.
4. Turn off engine and disconnect the Throttle Position Sensor (TPS)
5. Start engine. Rev engine (2,000-3,000 rpm) 2 or 3 times under no-load [This will lock the engine in timing mod]. Let engine run at idle speed then check and set timing.

Alternate Timing Method:

This procedure is a lot simpler than the one listed in the FSM. Warm up the car to normal operating temperatures, disconnect the TPS while the car is still running, rev the engine three times to about 3,000 rpm to lock in the engine in timing mod, then adjust the timing. I like this procedure and I will use it. While the TPS is still disconnected, you can check your idle speed. The FSM recommends setting your base idle (with TPS disconnected). To adjust your base idle turn the idle speed adjusting screw to your left. After your done reconnect the TPS.

Re: S13 redtop SR20DET timing weirdness

Posted: 18 Jan 2016 19:24
by jovial_cynic
Yup - I've done all of that.

I do think there is something wrong, possibly with the CAS gear. I went ahead and took both of the CAS bolts out and pulled the timing by turning the CAs beyond where the bolts would typically stop me, and the pinging completely went away. I could rev the engine all the way up without pinging.

This is confusing, because all of my timing markers are lined up, as stated in my first post. Without anything else that could possible impact the timing, I think the only thing I can think to do is to simply dial the CAS tooth back a couple of teeth and call it a day. I HATE that solution, because it makes future troubleshooting a pain, but I'm really not sure what else to do.

Re: S13 redtop SR20DET timing weirdness

Posted: 18 Jan 2016 20:53
by jovial_cynic

There is the slightest possibility that I misread the CAS timing marks.

Re: S13 redtop SR20DET timing weirdness

Posted: 29 Mar 2016 03:42
by Dillinja
When you stab the CAS you're lined up with the rear mark first while the bolt hole is lined up in the middle of the CAS right? After its fully stabbed in you should be on the second one. If you have the stock water outlet you have to get the teeth of the CAS close then line up the bolt hole.