the right thermister for stock 510 temp gauge

Paint, body preparation and modification, interior work and electrical
Post Reply
deano510
Posts: 167
Joined: 16 Dec 2013 18:42
Location: NorCal

the right thermister for stock 510 temp gauge

Post by deano510 » 30 Jun 2016 18:16

I'm using the stock 510 temp gauge but it doesn't register any change in temp. Maybe because I'm using the thermistor on the KA24 engine I've swapped into my 2dr sedan. Does anyone know the correct thermistor to use with the stock 510 temp gauge?

Dean
deans510@gmail.com

510rob
Moderator
Posts: 4638
Joined: 09 Oct 2003 23:37
Location: Vancouver, BC
Contact:

Re: the right thermister for stock 510 temp gauge

Post by 510rob » 30 Jun 2016 19:08

Here are some readings I took from an L-Series temp sensor.
  • For temp control, I used a PID-controlled water bath with an PT100 RTD type temp probe, which typically achieves temp control to better than 1/4°C.
  • For each temp point, the setup was left to stabilize for at least 10 minutes.
  • For resistance measurement, I used a typical (decent quality) multimeter. I did not have access to a proper 4-wire normalized setup, so I used what I had access to.
  • I did not sample a group of sensors and average the readings, I only sampled the one sensor that was handy (very unscientific but good and lazy!)
  • I did not bother with an ice-bath to get the zero point, because the stock gauge doesn't read down there anyway!
Here are the data points I measured.

34.5°C = 941°F = 266Ω
40.2°C = 104°F = 209Ω
50.0°C = 122°F = 147Ω
60.0°C = 140°F = 102Ω
70.0°C = 158°F = 71.0Ω
80.0°C = 176°F = 52.3Ω
90.0°C = 194°F = 39.0Ω
95.0°C = 203°F = 33.5Ω
98.0°C = 208.4°F = 29.7Ω
99.5°C = 211.1°F = 28.7Ω

User avatar
okayfine
Supporter
Posts: 14136
Joined: 12 Nov 2007 23:02
Location: Newbury Park, CA

Re: the right thermister for stock 510 temp gauge

Post by okayfine » 30 Jun 2016 20:31

Dean, did you try grounding the sensor wire to see if the gauge maxes out? Verifying the wire and gauge are good? Old DQ has a repair article.

The last SR swap I had in Whitebird had a stock 510 sender in the 240SX sensor bung plumed in to the return hose. I posted about that piece here a while back. I forget what I used for the first SR, I'll have to look at pictures.
Because when you spend a silly amount of money on a silly, trivial thing that will help you not one jot, you are demonstrating that you have a soul and a heart and that you are the sort of person who has no time for Which? magazine. – Jeremy Clarkson

Post Reply